Bet99

Cloudflare Global Outage
Resolved·Degraded performance

Monitoring - A fix has been implemented and we believe the incident is now resolved.

Tue, Nov 18, 2025, 03:27 PM
(3 weeks ago)
·
Affected components
Website
App
Updates

Resolved

Monitoring - A fix has been implemented and we believe the incident is now resolved.

Tue, Nov 18, 2025, 03:27 PM

Monitoring

A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal

Tue, Nov 18, 2025, 02:44 PM(42 minutes earlier)

Identified

Some services are beginning to recover. Cloudflare have made some changes and are seeing reductions in error rates

Tue, Nov 18, 2025, 02:16 PM(27 minutes earlier)

Identified

Cloudflare have acknowledged an issue within their internal Network and Infrastructure

Tue, Nov 18, 2025, 02:12 PM
Powered by